POLi Payments Platform outage resolved
Incident Report for POLi Payments StatusPage
Resolved
This incident has been resolved.
Posted Nov 23, 2021 - 17:54 AEDT
Investigating
We are currently investigating the issue.
Posted Nov 23, 2021 - 17:42 AEDT
This incident affected: POLi Platform.